House of Fusion
Search over 2,500 ColdFusion resources here
  
Home of the ColdFusion Community

Mailing Lists
Home /  Groups /  ColdFusion Talk (CF-Talk)

Message: HTTP/1 1 200 OK Server: Microsoft-IIS/5 0

  << Previous Post |  RSS |  Sort Oldest First |  Sort Latest First |  Subscribe to this Group Next >> 
Top  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Stan Winchester
04/02/2003 02:26 PM

Over the past several months I have noticed what looks like a http header at the top of some of my pages. The message displays in both IE & NS. Please see below example:

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Stan Winchester
04/02/2003 04:42 PM

For some reason the full message did not display, so I am reposting it below: =========================== HTTP/1.1 200 OK Server: Microsoft-IIS/5.0 Date: Wed, 02 Apr 2003 17:01:32 GMT Connection: close Content-type: text/html Page-Completion-Status: Normal Page-Completion-Status: Normal ============================ If I do a refresh the message goes away. Any ideas what is going on and how to prevent the message from appearing in the first place? Stan Winchester AfterShock Web Design, LLC stan@aftershockweb.com http://www.aftershockweb.com/

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Critz
04/03/2003 07:45 AM

oi Stan!! I believe it's due to using <cflocation....> you can get around it by using <cfheader name="location" value="page_goes_here"> <cfheader statuscode="302" statustext="Moved temporarily"> <cfabort> ------------------------------------ Wednesday, April 2, 2003, 2:23:12 PM, you wrote: SW> Over the past several months I have noticed what looks like a http header at SW> the top of some of my pages. The message displays in both IE & NS. Please SW> see below example: SW>

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Stan Winchester
04/03/2003 02:14 PM

Critz, Thank you for your suggestion. It looks like the problem was in fact <cflocation....>. The below solution worked perfectly: <cfheader name="location" value="../index.cfm"> <cfheader statuscode="302" statustext="Moved temporarily"> <cfabort> Upon further investigation I found that the custom tag <cf_location....> also works because it does exactly the same thing as the above solution. The obvious advantage for using the custom tag <cf_location....> is that I can do saver global search & replaces very easily without fear of breaking code. One last note: The <cflocation....> issue seems to be an issue only with Windows client browsers and not on other platforms; I cannot reproduce the header message on a Mac, thought I have not tried a Linux box yet. Thank you, Stan Winchester AfterShock Web Design, LLC stan@aftershockweb.com http://www.aftershockweb.com/ Tel. 503-244-3440 Fax 503-244-3454

Top  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Axiomatique (Vincent)
04/03/2003 12:43 AM

We had the same problem, and finally we found out that the client getting that header on the top of the pages was using a firewall on his machine. The user that was getting this problem was using the firewall "ZoneAlarm pro", When the firewall is disabled, the "HTTP/1.0 200 OK ...." would not display. I am guessing it has to do with some settings on his firewall. -----Message d'origine----- De : Stan Winchester [mailto:stan@aftershockweb.com] Envoyé : April 2, 2003 10:41 PM À : CF-Talk Objet : Message: HTTP/1.1 200 OK Server: Microsoft-IIS/5.0... For some reason the full message did not display, so I am reposting it below: =========================== HTTP/1.1 200 OK Server: Microsoft-IIS/5.0 Date: Wed, 02 Apr 2003 17:01:32 GMT Connection: close Content-type: text/html Page-Completion-Status: Normal Page-Completion-Status: Normal ============================ If I do a refresh the message goes away. Any ideas what is going on and how to prevent the message from appearing in the first place? Stan Winchester AfterShock Web Design, LLC stan@aftershockweb.com http://www.aftershockweb.com/

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
samcfug
04/03/2003 10:09 AM

Another cause could be due to a slightly mis-configured URLScan ISAPI filter on the server. ===================================== Douglas White group Manager mailto:doug@samcfug.org http://www.samcfug.org ===================================== | We had the same problem, and finally we found out that the client getting | that header on the top of the pages was using a firewall on his machine. | The user that was getting this problem was using the firewall "ZoneAlarm | pro", | When the firewall is disabled, the "HTTP/1.0 200 OK ...." would not display. | I am guessing it has to do with some settings on his firewall. | | | -----Message d'origine----- | De : Stan Winchester [mailto:stan@aftershockweb.com] | Envoyé : April 2, 2003 10:41 PM | À : CF-Talk | Objet : Message: HTTP/1.1 200 OK Server: Microsoft-IIS/5.0... | | | For some reason the full message did not display, so I am reposting it | below: | =========================== | | HTTP/1.1 200 OK Server: Microsoft-IIS/5.0 Date: Wed, 02 Apr 2003 17:01:32 | GMT Connection: close Content-type: text/html Page-Completion-Status: Normal | Page-Completion-Status: Normal | | ============================ | | If I do a refresh the message goes away. Any ideas what is going on and how | to prevent the message from appearing in the first place? | | Stan Winchester | AfterShock Web Design, LLC | stan@aftershockweb.com | http://www.aftershockweb.com/ | |

Top  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
A.Little
04/03/2003 02:53 AM

I've come across the same problem  - only occassionally though and I can't reliably reproduce it. I did find though that it only occured when the page was displayed as a result of submitting a <cfform>, I couldn't get to reproduce the error at all if the page was called from a normal html <form> HTH Alex ----- Excess quoted text cut - see Original Post for more -----

Top  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
James Ang
04/03/2003 02:38 PM

The reasons for the MS IE only problem: 1) HTTP/1.1 Keep-Alive or Persistent Connection feature that both IIS and MS IE supports. I am not sure if Gecko supports Keep-Alive. 2) CFLOCATION causes the CF Server to miscalculate and hence, misinform MS IE, the value for the CONTENT-LENGTH header. It was too short. 3) MS IE uses the value in CONTENT-LENGTH to clear the appropriate amount of the output buffer. Hence, it has left-overs. THEN, re-using the same HTTP connection, MS IE retrieves the URL specified in the LOCATION header, and append to the current output buffer. The output buffer is fed to the HTML rendering engine, and voila, you get junk on top. This issue does not exists in MS IE if: 1) the CFLOCATION url does not point to the same server name (cnn.com versus www.cnn.com) 2) the protocol of the CFLOCATION URL is not the same as the previous call (HTTP versus HTTPS) Which causes MS IE to terminate the current connection, and connects to the appropriate server specified in the URL. One quick way to duplicate this problem is to use CFHTMLHead in conjunction with CFLOCATION. The string length passed to CFHTMLHead must exceed the amount that would be specified by ColdFusion in the erroneous CONTENT-LENGTH header. As an aside, the CONTENT-LENGTH header's value is calculated based on the HTML that would be presented to a browser when it does not understand HTTP STATUS 302 (Object Moved) which is automatically generated by the ColdFusion server when it executes CFLOCATION. The length is variable because it depends on the length the CFLOCATION URL. :) This is a KNOWN problem. Not sure when it will ever get fix. ;) ------------------------------- James Ang Sr. Developer/Product Engineer MedSeek, Inc. jang@medseek.com Critz, Thank you for your suggestion. It looks like the problem was in fact <cflocation....>. The below solution worked perfectly: <cfheader name="location" value="../index.cfm"> <cfheader statuscode="302" statustext="Moved temporarily"> <cfabort> Upon further investigation I found that the custom tag <cf_location....> also works because it does exactly the same thing as the above solution. The obvious advantage for using the custom tag <cf_location....> is that I can do saver global search & replaces very easily without fear of breaking code. One last note: The <cflocation....> issue seems to be an issue only with Windows client browsers and not on other platforms; I cannot reproduce the header message on a Mac, thought I have not tried a Linux box yet. Thank you, Stan Winchester AfterShock Web Design, LLC stan@aftershockweb.com http://www.aftershockweb.com/ Tel. 503-244-3440 Fax 503-244-3454


<< Previous Thread Today's Threads Next Thread >>

Search cf-talk

July 25, 2014

<<   <   Today   >   >>
Su Mo Tu We Th Fr Sa
     1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31     

Designer, Developer and mobile workflow conference