House of Fusion
Search over 2,500 ColdFusion resources here
  
Home of the ColdFusion Community

Mailing Lists
Home /  Groups /  ColdFusion Talk (CF-Talk)

JRun grabbing port 443 before IIS can preventing https

  << Previous Post |  RSS |  Sort Oldest First |  Sort Latest First |  Subscribe to this Group Next >> 
Top  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
DURETTE, STEVEN J
03/14/2012 09:38 AM

Hi all, I have an issue where we have an intranet server that is https for all requests all of the time. Every time the server is rebooted (I hate patch Tuesday) The service "Macromedia JRun CFusion Server" starts up before IIS and grabs hold of port 443. Then IIS starts and gets denied access to port 443. This stops all of our websites on this box from working. I should also mention that this is CF8 Enterprise with multiple ColdFusion Instances. Can anyone tell me how to let IIS come up first and get the port as it is supposed to before JRun grabs it? Thanks, Steve

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Matthew Small
03/14/2012 10:40 AM

Make the Macromedia JRun CFusion Server service dependant on the World Wide Web Publishing Service - IIS will start before JRun every time. http://support.microsoft.com/kb/193888 - Matt ----- Excess quoted text cut - see Original Post for more -----

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
DURETTE, STEVEN J
03/14/2012 11:04 AM

Thanks, I found that too. I was just hoping that there was something non registry related. I'll go with this though! This list is the best!!! Steve Make the Macromedia JRun CFusion Server service dependant on the World Wide Web Publishing Service - IIS will start before JRun every time. http://support.microsoft.com/kb/193888 - Matt

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Russ Michaels
03/14/2012 12:20 PM

do you have the cfusioninternal web server enabled, as that must be what is causing it to use port 443. If you disable the internal web server then you wont have that issue any longer. ----- Excess quoted text cut - see Original Post for more -----

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Dave Watts
03/15/2012 09:48 AM

> I have an issue where we have an intranet server that is https for all requests all of the time. Every time the server is > rebooted (I hate patch Tuesday) The service "Macromedia JRun CFusion Server" starts up before IIS and grabs hold > of port 443. Then IIS starts and gets denied access to port 443. This stops all of our websites on this box from working. > > I should also mention that this is CF8 Enterprise with multiple ColdFusion Instances. > > Can anyone tell me how to let IIS come up first and get the port as it is supposed to before JRun grabs it? While Matthew's answer is absolutely correct, Russ's answer corresponds to the question you should have asked. Configure JRun not to use TCP/443 rather than depend on another service starting up first. https://www.adobe.com/support/coldfusion/adv_development/config_builtin_webserver/ Dave Watts, CTO, Fig Leaf Software http://www.figleaf.com/ http://training.figleaf.com/ Fig Leaf Software is a Veteran-Owned Small Business (VOSB) on GSA Schedule, and provides the highest caliber vendor-authorized instruction at our training centers, online, or onsite.

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
DURETTE, STEVEN J
03/15/2012 09:54 AM

I did the registry entry. However I double checked and when ColdFusion was installed we did not turn on the internal web server.  I will however double check this as well.  Someone may have been messing with the config files and not telling me. > I have an issue where we have an intranet server that is https for all requests all of the time. Every time the server is > rebooted (I hate patch Tuesday) The service "Macromedia JRun CFusion Server" starts up before IIS and grabs hold > of port 443. Then IIS starts and gets denied access to port 443. This stops all of our websites on this box from working. > > I should also mention that this is CF8 Enterprise with multiple ColdFusion Instances. > > Can anyone tell me how to let IIS come up first and get the port as it is supposed to before JRun grabs it? While Matthew's answer is absolutely correct, Russ's answer corresponds to the question you should have asked. Configure JRun not to use TCP/443 rather than depend on another service starting up first. https://www.adobe.com/support/coldfusion/adv_development/config_builtin_webserver/ Dave Watts, CTO, Fig Leaf Software http://www.figleaf.com/ http://training.figleaf.com/ Fig Leaf Software is a Veteran-Owned Small Business (VOSB) on GSA Schedule, and provides the highest caliber vendor-authorized instruction at our training centers, online, or onsite.

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
DURETTE, STEVEN J
03/15/2012 12:02 PM

Strangely, the <attribute name="deactivated"></attribute> didn't exist. The document linked was for CFMX, but I added the tag with a value of true.  We shall see what happens. :) While Matthew's answer is absolutely correct, Russ's answer corresponds to the question you should have asked. Configure JRun not to use TCP/443 rather than depend on another service starting up first. https://www.adobe.com/support/coldfusion/adv_development/config_builtin_webserver/ Dave Watts, CTO, Fig Leaf Software http://www.figleaf.com/ http://training.figleaf.com/

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
Dave Watts
03/15/2012 07:03 PM

> Strangely, the <attribute name="deactivated"></attribute> didn't exist. The document linked was for CFMX, but I added the tag with a value of > true.  We shall see what happens. :) Everything in the document applies to current versions of CF running on JRun 4. Dave Watts, CTO, Fig Leaf Software http://www.figleaf.com/ http://training.figleaf.com/ Fig Leaf Software is a Veteran-Owned Small Business (VOSB) on GSA Schedule, and provides the highest caliber vendor-authorized instruction at our training centers, online, or onsite

Top  |   Parent  |   Reply  |   Original Post  |   RSS Feed  |   Subscribe to this Group
Author:
DURETTE, STEVEN J
03/16/2012 07:50 AM

Adding that line caused the ssl connections to SQL server to fail. Had to take it back out. Just going to live with the registry change for now. Hopefully things will change if we get to upgrade to CF9/10. Steve > Strangely, the <attribute name="deactivated"></attribute> didn't exist. The document linked was for CFMX, but I added the tag with a value of > true.  We shall see what happens. :) Everything in the document applies to current versions of CF running on JRun 4. Dave Watts, CTO, Fig Leaf Software http://www.figleaf.com/ http://training.figleaf.com/


<< Previous Thread Today's Threads Next Thread >>

Search cf-talk

December 22, 2014

<<   <   Today   >   >>
Su Mo Tu We Th Fr Sa
   1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31       

Designer, Developer and mobile workflow conference